dpaste instance offline
Incident Report for Darren Nathanael's Infra
Postmortem

Hello everyone! As some of you might know, dpaste used to run on Glasshost infrastructure while I was a part of Glasshost.

Due to some internal conflict, there was a miscommunication, and the dpaste VPS was removed entirely. Not just dpaste—if you have noticed, my entire stack was removed from the Glasshost infrastructure, which is unfortunate timing.

Some services have active backups, while some do not, including dpaste, which does not have an active backup.

So, I had to roll back dpaste to an older database copy from 2023.

--

So that’s that. Going forward, dpaste will run on my home infrastructure. The hardware it’s running on is a Ryzen 5 5500 machine. There are some concerns regarding the network & power, which I have solved ish—my entire house are backed with a redundant network (2 ISPs), and an AVR before the main power hits any equipment.

Posted Jul 21, 2024 - 11:52 UTC

Resolved
This incident has been resolved. dpaste has been stable for 48 hours now.
Posted Jul 16, 2024 - 10:48 UTC
Monitoring
I've have completely migrated dpaste to Darren's fully owned infrastructure. Unfortunately, due to this incident, I am unable to obtain the latest database backup. The most recent copy of the database is from prod_20230508_213709.

A post-mortem report will be provided soon with more details.

-darren
Posted Jul 14, 2024 - 20:42 UTC
Investigating
We are aware that the primary dpaste.org instance is down
Posted Jul 14, 2024 - 19:36 UTC
This incident affected: dpaste Infrastructure (dpaste - core).